Sunday, May 16, 2010

DV9000 Overheating

A DV9208 arrived with overheating problems. Luckily it was caught before it started generating additional issues with the GPU.


Symptoms:
Unit would overheat, cause shutdown/off without notice.
WIFI would turn off
Cause:
Heat sink vents 75% blocked, so insufficient cooling was the culprit.
Repair:
Disassemble unit, disassemble heat sink, clear vents.
Problem #2 was a little more different. Because the Southbridge
would also overheat, causing loss of contact on solderballs.

Solution:
Clearing the lint from heatsink will remedy issue with overheating/shutdown. Since no drive arrived with unit a substitute drive was used to run system for several hours, then turned off, and test again.  I do this about 4 tests so that nothing happens when it gets back to the customer.


Aluminum heat transfer pad for CPU
replaced with copper pad.  The pad
from HP is only ok, but many times the CPU gets so hot that the Aluminum breaks down and sticks to the CPU. Not providing a good thermal transfer.

Reflow process is done to both GPU and SouthBridge. 60 day Warranty offered

8 comments:

  1. your theoory is great about reflow of southbridge ic.here in my place peoples not know the importance of southbridge.it has same inportance like GPU

    ReplyDelete
  2. I've repaired my fair share of overheating laptops and I have a DV9000 that's puzzling me no end. The fan vents are clean, spotless, I've replaced the TIM with AS5 and even tried adding additional copper sinks and another fan and it still overheats! But what is most puzzling of all, is that the air coming out the fan exhaust vent is COLD!

    So for some reason, the heat is not travelling up the heatpipe into the exhaust fan fins, the sinks are making good contact with both the GPU and CPU dies.

    Very confused.

    ReplyDelete
  3. Zoid: the pipes can fail too. Rarely but they do. I am not exactly sure of what heatsink compound you are using, or if the silicone pads have been removed and the aluminum transfer pads on the (AMD) CPU. These do provide transfer, but the actual attraction is heat traveling to a cooler surface (tubes).

    I have on one occasion found it to be the thermal sensor in the fan itself. The resistance stays in place and never signals the fan to come on. I hadn't measured if it was high or low, but was not sensing changes. Replaced fan and the transfer worked normally. Google "SpeedFan" and try that for some of the thermal tests.

    ReplyDelete
  4. OH yes I run speedfan on pretty much all my laptops :) AS5 = arctic silver 5.

    Still didn't work out what was going on with that DV9000, unless I throttle the CPU to 75% is invariably overheats.. might be the T5750, pretty hot CPU.

    ReplyDelete
  5. Zoid: Forgot to ask you if you had cleaned the inside of the heatsink, checked to see if GPU is resting on the pad or shim (if using one)? Hopefully it is not overclocked too.

    ReplyDelete
  6. Actually I underclock and undervolt it, otherwise it overheats much faster.

    Contact with copper shim is good and I've cleaned and re-seated the heatsink so many times now I've lost count, each time I dismantle the unit thinking I must have missed something and each time I'm getting the same result, it's like the heat just does not xfer to the heatsink fins and so never leaves the heatpipe..

    ReplyDelete
  7. Just tore down the A900 (DV9000) again, removed the second fan I'd installed, installed a Celeron 1.6 hoping it'd run cooler than the 2ghz c2d, same result, idle temp 65c, load 90c+.
    Exhaust air is cool.
    I've noticed if I block the primary air intake intentionally this will force the air to draw from further away and *may* lower the temperatures, but once it starts heating up it just keeps rising.
    It seems the heat is being generated primarily by the GPU, the CPU and GPU temps are always within 5 degrees on account of them sharing the same heatpipe:
    |GPU|===|CPU|===|FAN|

    It seems like an airflow problem.

    ReplyDelete
  8. Hmm, perhaps the A900 isn't identical to the DV9000 - I just examined your image of the HS and it seems the CPU block is first, then the GPU and then the fan, wheras on mine the GPU block is on the outside.. I wonder if this could be what makes it so much less efficient?

    ReplyDelete

I cannot repair laptops for you via the internet, I can only answer questions related to posts. This is because I have not had experience on every motherboard that is out there. Bear with me.

If you do need it repaired. Contact me for quote (US/CDN Only)

Note: Only a member of this blog may post a comment.